How to prevent Chatbot from answering facebook messages?

3 Comments

  • Greg - Community Manager
    Comment actions Permalink

    Hi David! Thanks for providing all of this context, as well as the steps you've already taken and how that played out for you. Could you let me know what tools you're using to have a bot respond to your Facebook messages? From what I can tell, you do not currently have any Facebook pages linked to your instance so anything that you can share here will help me figure out the root of the issue and then a possible solution.

    Thanks!

    0
  • David A
    Comment actions Permalink

    We'd since disconnected our Facebook and Twitter pages while we looked for a solution. I'm not exactly sure how the original integration was setup, however, I see that an Ap called Zendesk Messenger app has permissions to our Facebook page. Does this help?

    0
  • David A
    Comment actions Permalink

    Thanks for your help

    Update: I've relinked our Facebook page to our Zendesk account. However, I'm not able to have Facebook page messages turn into tickets without having our chatbot trying to respond to all of our Facebook messages. This is what the integration looks like on Facebook:

    This is what the integration looks like on our side (https://company.zendesk.com/admin/channels/channels_list/edit/#####):

     

    In order for messages to be turned into tickets, we have to enable the Handover Protocol option for Zendesk, however, when we enable this, all Facebook messages are making it into the subscription that our chatbot listens to via the Conversations API. Also based on the documentation, we don't see a way to distinguish which messages are from Facebook, so we can't implement a check to prevent our chatbot from answering these messages:

    In the meanwhile, we've turned off the handover protocol option for Zendesk to prevent our chatbot from disturbing our Facebook page.

    0

Please sign in to leave a comment.

Powered by Zendesk