Mixed Content using ZAT / Chrome

4 Comments

  • Bryan - Community Manager
    Comment actions Permalink

    Hi Fabien --  if you're using the '?zat=true' option when debugging an Apps framework app and in Chrome, you should see a 'shield' icon on the right side of the URL/address bar. Clicking on that and then clicking 'Load unsafe scripts' is needed.

    The above screen shot came from this article: https://help.optimizely.com/Troubleshoot_Problems/Troubleshooting%3A_Compatibility_mode_warning_and_mixed_content_in_the_Editor

    Sometimes the browser's Console window will show "Mixed Content" warnings but the content itself isn't blocked. If you're not seeing the shield icon, this may be the case. You'll want to determine what content is actually being blocked if any. Hope this helps.

    0
  • Roman Sheydvasser
    Comment actions Permalink

    The shield icon doesn't seem to come up in Chrome 79.0.3945.130.

    We were able to work around this by going to Chrome Settings/Advanced/Privacy and Security/Site Settings/Insecure Content and adding our Zendesk subdomain under the Allow list there.

    Firefox worked without a workaround as described in the article here: https://develop.zendesk.com/hc/en-us/articles/360001075048

    1
  • Bryan - Community Manager
    Comment actions Permalink

    Thanks Roman Sheydvasser for sharing that! I'll work on getting the documentation updated.

    For others, these are screen shots on how to get to the option that Roman mentions...

    Edit:

    2
  • Russell Dunn
    Comment actions Permalink

    I literally came in to post this as I'd lost the shield icon as well and was beginning to tear my hair out.

    Thanks Roman!

    0

Please sign in to leave a comment.

Powered by Zendesk