Is it possible to exclude files from app package?

5 Comments

  • Joey
    Comment actions Permalink

    Hi there Dru-

    Are you compiling this then running zat server in the /dist directory?

    Thanks,

    Joey

    0
  • Aleksey Kislov
    Comment actions Permalink

    Any update on this? Faced the same issue when zat theme preview stopped worked and just been loading the theme infinitely. zat validate outputted Too many open files @ rb_sysopen because of node_modules in the same directory. Is there workaround for this (like ingoring specific folders)?

    0
  • Dru Kepple
    Comment actions Permalink

    I guess I never responded to Joseph's comment to say, "oh, duh..." Yes, I reconfigured my project to build into a "dist" folder to keep source files separate.  I'd estimate it took a bit more configuration than it would if there was an "exclude" option in manifest.json....but at least it works and I can enjoy using NPM modules, and Babel and Webpack...

    0
  • Aleksey Kislov
    Comment actions Permalink

    Same here, guess it's the only option. Thanks for reply.

    0
  • Joey
    Comment actions Permalink

    Hey Dru & Aleksey-

    I'll confirm it as the only option that I am aware of.

    0

Please sign in to leave a comment.

Powered by Zendesk