Cannot create app: Attachment content type is invalid, Attachment is invalid

Completed

7 Comments

  • Sebastiaan Wijchers
    Comment actions Permalink

    Hello haribalaji ravi,

    I don't know that error, but it sounds like your zip file isn't a zip file.

    Did you package your app with the zat package command? That's part of the Zendesk Apps Tools. It will validate and zip your app.

    With kind regards,

    Sebastiaan
    Sparkly ⭐

    0
  • haribalaji ravi
    Comment actions Permalink

    Of course I was used that command. 

    0
  • korolev
    Comment actions Permalink

    I have updated the app success 20 hours ago. And It's failed When I update the app 16 hours ago, It's the same error as Haribalaji said. Even though I try to use the current app version to update. 

    0
  • haribalaji ravi
    Comment actions Permalink

    I got the above error while submitting the app. How can we resolve this issue... Everything in the zip was perfect as in the docs. Even, since last week we tested our app in private mode it works fine. But, now we set private: false. But, still got those errors.

    0
  • Phil Grove
    Comment actions Permalink

    Hi Haribalaji,

    We are looking into this issue and hope to have a fix deployed soon. Please bear with us and I will update this post with an update soon.

    Best regards, Phil.

    0
  • Phil Grove
    Comment actions Permalink

    Hi Haribalaji,

    We have deployed a fix for this issue. Please let me know if you still experience problems uploading your app.

    Regards, Phil.

    0
  • haribalaji ravi
    Comment actions Permalink

    Hi Phil Grove,

    Thanks for the update. Its working fine now. We have submitted the app successfully.

    0

Please sign in to leave a comment.

Powered by Zendesk